Dev Team Updates Redsn0w; Adds Native Support For iOS 5.0.1, Fixes iBooks Issue And Lots More

News | Saturday December 17 2011 11:00 PM | Comments (0) Tags: , , , , , , , , , ,

As promised, iPhone Dev team has released a new version of
 – a popular jailbreaking tool, which brings native support for
, fixes the iBooks issue in iOS 5 and iOS 5.0.1 and lots more.
Redsn0w 0.9.9b9b will also allow users to downgrade using iOS 5.x. SHS blobs.
The holiday season is almost here (Happy Holidays!) so we realize everyone is busy (especially @pod2g!).  And even though we always recommend that jailbreakers stay where they are until a new untethered JB comes out, that’s not always possible.  So we’ve updated redsn0w for those who may have found themselves at iOS 5.0.1, and added some other useful features too:
native support for 5.0.1 (no need to point redsn0w at 5.0 IPSW or use command-line args).  Support automatically extends to all of redsn0w’s various functions: “Jailbreak”, “Just boot”, “Fetch blobs”, “Stitch blobs”, “Recovery Fix”
iBooks fixed in 5.0 and 5.0.1.  This is a targeted fix that doesn’t remove entire sandbox mechanism.  5.x users already using redsn0w “Just Boot” can just use the new version without redoing entire jailbreak again
ultrasn0w compatability update (i.e. same baseband requirements) for 5.0.1 will be available on Cydia Monday
support for newer 8GB iPhone 4 (which until now had problems with “Fetch blobs”).  Thanks to @JKjeepnJeff for loaning us one of these newer i4 units for testing!
allows Windows users (not just OS X users) to use the “Custom” button to create IPSWs without baseband updates.  
accommodates APTickets in 5.x (until next Apple countermove).  APTickets are crypto-verified before submitting to Cydia, just like the main blobs.  Cydia server support for sending back the APTickets is upcoming.  For now, use stitched IPSWs for 5.x.  Due to APTickets, stitched 5.x IPSWs now require user to start in “Pwned DFU” mode
Support added for stitching 4.x blobs to iPad2-GSM IPSWs.  Similar to @notcom’s TinyCFW but doesn’t require lots of RAM or a TSS-assisted restore. Won’t work for iPad2 5.x blobs (or iPhone 4S at all) until a bootrom-level exploit is out
top line now shows whether (and where) a redsn0w update is available, or if the version being run is the latest.  Uses DNS TXT record to alleviate any concerns about snooping
no 5.1 beta support at this time (major apps like Cydia are not yet compatible)
@pod2g has been doing a great job porting his 5.x untether…check
for updates!
.  The iPad baseband will not work on 3GS iPhones built later than 2011 week 35.  You have a week 35 or later device if your serial # starts with xx135.

No Comments »

No comments yet.

RSS feed. TrackBack URI

Leave a comment

You must be logged in to post a comment.